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Step-by-Step Guide: Recovering Data with GetDataBack Pro 

This guide explains how to recover data using GetDataBack Pro and how to prepare 
your system properly before you begin. 

Before You Begin 

Do not write anything to the drive you want to recover data from! 

This is the single most important rule. After data loss, the operating system no longer 
protects your files the way it did before. It may treat the space containing your lost files 
as free space. Any of the following actions could permanently overwrite your data: 

• Installing programs 
• Copying files 
• Browsing the internet 
• Booting from the affected drive 

The sooner you stop using the drive, the better your chances of recovering your data. 

In this guide: 

• The drive you are recovering data from will be referred to as the “Bad Drive.” 
• Any other drive — such as the system drive or the drive where recovered files 

are saved — will be referred to as a “Good Drive.” 

GetDataBack Pro performs read-only operations during scanning and does not modify 
the Bad Drive. 

I. Preparing the Recovery Environment 

I.I. Setting up a Recovery Computer 

The safest way to recover data is to connect the Bad Drive to a separate working 
computer (the “Recovery Computer”). 

• If the Bad Drive is your boot drive (C:): Remove it and connect it to 
another computer as a secondary drive. Instructions are provided in Section 
I.II. 
 

• If the Bad Drive is already a secondary or external drive: You may 
leave it connected and proceed directly to installation (Section II). 
 

• If the Bad Drive comes from a laptop or notebook: See Section I.II.I. 
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I.II. Removing the Bad Drive and Connecting It to Another Computer 

If you have never removed or installed a hard drive before, do not worry — the 
process is straightforward. 

1. Shut down the computer completely. 
2. Unplug the power cable. 
3. Open the computer case (usually secured with a few screws). 
4. Locate the hard drive connected to a SATA cable and a power cable. 
5. You may need to remove additional screws securing the drive. 
6. Disconnect the SATA cable and power cable. 
7. Remove the drive. 

The drive is now removed. Install the Bad Drive in your Recovery Computer as a 
secondary drive. 

 
 
You Have Two Options 

Option 1: Use another working computer. 
Install the Bad Drive as a second drive. Make sure that this computer has enough free 
space to store the recovered files. You may use a friend’s computer if necessary, but 
ensure that they agree to you copying your recovered data to their drive. 

Option 2: Use your existing system as the Recovery Computer. 
Install a new hard drive with enough space to hold the recovered data. Install Windows 
7 or later on this new drive, make it the system boot drive, and attach the Bad Drive as 
a secondary drive. 

Before attaching the Bad Drive, boot the Recovery Computer first and confirm that it 
starts normally from its Good Drive. 

Connect the Bad Drive using an available SATA cable and power connector. If no spare 
cable is available, you may temporarily disconnect a DVD drive and use its cables. 
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If the only available computer you can use as a Recovery Computer is a notebook or 
laptop, you will not be able to connect the Bad Drive directly to a SATA cable.  

Reconnect the computer’s main power cable and start the Recovery Computer. 

Make sure the system boots from the Good Drive. If it attempts to boot from the Bad 
Drive, enter the BIOS and adjust the boot order first (common keys include F1, F2, 
F10, F12, Delete, or Esc). 

Once the system boots correctly, confirm that the Bad Drive is detected: 

1. Press Windows + R 
2. Type diskmgmt.msc 
3. Press Enter 

If the Bad Drive does not appear in Disk Management, it may be physically damaged or 
incorrectly connected. If you suspect physical damage, consider contacting a 
professional data recovery lab. Otherwise, check the cables and BIOS settings. If 
needed, seek assistance from a local computer technician. 

I.II.I Special Case – Laptop Drive 

If you need to recover data from a notebook or laptop drive, you have the following 
options: 

Option 1 (Recommended): Remove the drive from the laptop and connect it to a 
desktop computer as described above. Most modern laptops allow drive removal by 
removing a few screws. Always power down completely before removing hardware. 

Option 2: Create a WinPE boot CD and run GetDataBack from it. You will still 
need another storage location (USB drive, external drive, or network drive) to save 
recovered files. Detailed instructions for creating a WinPE boot disk are available at: 
http://www.runtime.org/peb.htm. 

Option 3: Use the ready-to-use Runtime Live CD. This CD includes GetDataBack 
preinstalled. The ISO file can be downloaded from: http://www.runtime.org/data-
recovery-live-cd.htm 

I.II.II. Special Case – External Drives 

External drives, such as USB drives or SD cards, can be recovered with 
GetDataBack just like internal drives.  

http://www.runtime.org/peb.htm
http://www.runtime.org/data-recovery-live-cd.htm
http://www.runtime.org/data-recovery-live-cd.htm
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However, USB connections are slower and sometimes less reliable. If possible, 
remove the drive from its enclosure and connect it directly via SATA. If you prefer 
not to open the enclosure, simply allow extra time for the scan. 

II. Installation 

II.I Installing GetDataBack Pro 

Once your Recovery Computer is ready: 

1. Download the free demo version of GetDataBack Pro from 
http://www.runtime.org 

2. Install it on the Good Drive (typically C:). 

GetDataBack Pro supports NTFS, FAT, exFAT, Linux EXT, and Mac HFS+ and APFS file 
systems. 

http://www.runtime.org/
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III. Running GetDataBack Pro 

Launch the software. 

III.I. “Select Drive” Screen 

You will see a list of available drives. Each red square represents a physical drive:  

 

Select the drive that corresponds to your Bad Drive. If you attached the drive as a 
second drive as explained above, it would appear as “DISK1 (183 GB).” If you 
already have more than one hard drive in the system, it could appear as “DISK2”, 
“DISK3”, or similar. It should not be “DISK0”, as that would typically indicate the 
system boot drive. 

Click the square for the Bad Drive. 

III.II Scanning the Bad Drive 

GetDataBack will perform an initial scan to detect file system information. This 
usually takes only a few minutes. 
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The scan may take longer if: 

1. Your drive has physical problems. If the drive has a lot of bad sectors 
(damaged areas on the drive's platters that cannot be read anymore) or is 
otherwise damaged, the scan can take a very long time or may not finish at 
all.  
 
If you get only an occasional bad sector message, but the scan is otherwise 
progressing, choose "Ignore" in the warning windows and let the scan finish. 
 
However, if you receive many read error messages, or if the scan appears 
stalled or excessively slow, you should stop and create an Image of the 
damaged drive first. Creating an Image reduces stress on the drive, which, if 
physically damaged, could fail at any moment. Once you have created the 
Image, you can perform the data recovery for the Image instead of the drive 
— simply select the Image you created in the “Select Drive” screen of 
GetDataBack (click on “Image files…”).  
 
You can use GetDataBack to create an Image. The only additional 
requirement is sufficient free space on another drive to store the Image. 
Instructions on how to create an Image are available at 
http://www.runtime.org/gdbimage.htm. 
 

2. You are scanning an external drive through the USB port. Scanning a drive 
through USB takes longer than scanning a drive that is connected to the 
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internal SATA cable of your computer. Make sure you plug the drive into a 
USB-3 port (colored blue instead of black, or USB-C-shaped). Consider taking 
the drive out of its casing and attaching it directly to the SATA cable. See 
chapter I.II.II. External Drives above. 
 

3. You may be scanning with a high “Level”. Look at the purple rectangle in 
the lower left corner. A Level-4 (****) scan will take many hours to 
complete, as it will read every single sector, which is usually not necessary 
for a quality recovery.  

III.III “Select File System” screen 

After scanning, you will see the “Select File System” screen: 

 

On the left-hand side of the screen you will see a list of the possible file systems 
GetDataBack has found. Don't confuse the file system entries with the list of files 
and folders you are hoping to recover - you will see those in the next step of the 
software.  

Each entry represents a (possible) partition on the drive. If you had more than one 
partition on the drive which you need to recover (for example, logical drives C:\ and 
D:\), you may need to return to this screen and select the corresponding entries 
separately to recover all files. 

The file system entries are constructed using the information GetDataBack has 
collected during the scan. Later, this information will be used to reconstruct the file 
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system that was originally on the drive. By default, the most accurate file system 
entry is automatically placed at the top of the list, so for the moment don't be too 
concerned about the other entries. 

Right-click a file system rectangle to obtain a detailed description of the found file 
system. This information is primarily used by our tech support staff.  

So, click on the first entry in the list. GetDataBack will now perform another scan 
before it shows the “Recovery Tree” screen. You can follow the scan in the progress 
window. 

This operation can take anywhere from a few seconds to several hours, so you need 
to be patient. 

 

III.III.I No entries in “Select File System” screen 

If you do not see any entries here, this can be for the following reasons: 

1. Your drive is physically damaged and GetDataBack is unable to read 
enough sectors on the drive to gather the required information. If you were 
getting a lot of error messages during the scan or you already know that your 
drive has a physical problem, it might be too damaged for you to be able to 
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recover your data with software. You might have to send your drive to a data 
recovery lab. Please contact our tech support - they will help you determine if 
this is the case. 
 

2. You are scanning an external drive.  
Because there is no error checking during USB scans, any errors that occur 
while reading the drive won’t be communicated to GetDataBack. As a result, 
the software might not be able to access key file system information or 
gather enough data to create a file system entry. For faster and more reliable 
results, it is recommended to connect the drive directly to an internal SATA 
cable. Please see above I.II.II. Special Case - External Drives. 
 

3. The drive is hardware encrypted. 
Certain Western Digital USB drives use hardware encryption, with the drive’s 
enclosure USB controller managing both encryption and decryption. In these 
cases, the Bad Drive must be used with its original USB enclosure. 
 

4. The Level was too low. If you do not see an entry resembling the file system 
you are looking for, click on the purple “Level” rectangle in the lower left 
corner. Here you can increase the thoroughness with which the drive is 
scanned. Possible levels range from * to ****. 

III.IV. “Recovery Tree” 

The Recovery Tree resembles Windows Explorer: 
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On the left side of the screen you see a tree of recovered directories and folders and 
a folder called "Lost files" created by GetDataBack, containing the files without 
directory information. 

When you open a folder on the left side, the files in this folder are displayed on the 
right side. 

Begin by examining the left side. Does the directory tree look recognizable? Can 
you spot the folders from the drive you're trying to recover data from? Does the 
directory structure appear complete for this partition?  

Select a folder of interest from the panel on the left and review its contents 
displayed on the right. Confirm that the expected files are present within this folder, 
verify the accuracy of the file names, and ensure that all necessary files appear to 
be accounted for.  

Start by opening several files to check their contents. It's helpful to see the folders, 
file names, and correct file sizes, but it's crucial to confirm the actual file data. 
Some files, like very large ones or those needing specific programs—such as MySQL 
database files—might not be easy to test. Choose files that are simple to review, 
such as Word documents (*.doc), images (*.jpg), or graphics (*.gif). To view these 
files, double-click them or press F3 or ENTER to use the built-in viewer. If the 
appropriate application is installed on the Recovery Computer, you can also open 
files by right-clicking and selecting “Open”. 

If you’re able to view the contents—such as text and images—when you open the 
files, try this process on additional files stored in other folders. When most of your 
files open without issues, it’s a good sign that the recovery was successful.  

To save your recovered files, copy them from the Bad Drive to a different location. 
You can choose the boot drive of the Recovery Computer, any other connected 
drive, a USB drive, or even a network destination—just make sure wherever you 
choose has enough space for all your files. Never save the recovered files back 
onto the same drive (the Bad Drive) you retrieved them from; doing so may 
overwrite your data, causing it to be lost permanently! 

You can copy either individual files and folders by selecting them on the right side, 
or copy everything by choosing the top entry on the left labeled [FAT], [NTFS], 
[EXT], etc. After picking the files, folders, or the volume you want, press F5 or go to 
File → Copy in the main menu. 

To use the copy feature and save your files, you'll need a license key for the 
software. You can buy a license key online anytime at 
http://www.runtime.org/buy_now.htm. After submitting your order, you'll receive 
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the license key both via email and on the confirmation screen. There's no need to 
restart the program—simply enter the license key into the demo version of 
GetDataBack. In the main menu, select Help → License and input your registration 
name and key there. 

Copy your files and confirm all needed data is present on the destination drive 
before making any changes to the original drive. Do not reformat, reinstall an 
operating system, or recycle the old drive until you’re certain all necessary data has 
been recovered. Only then should you consider rebuilding the system. Do not reuse 
drives that show physical issues, contain bad sectors, or have experienced 
unexplained data loss. 

III.IV.I Problems & Troubleshooting 

If you can't find your files in the “Recovery Tree,” return to the “Select File 
System” screen and try other options. If they are still missing, click the purple 
“Level” rectangle in the lower left and increase the scan level (up to ****). If you 
still cannot find your data, send us a snapshot of your recovery along with a short 
description of what happened to your drive. You create a snapshot by clicking on 
Help → Snapshot for Support. This will create a small text file with detailed 
information about the options you selected in the software. Email this file to 
support@runtime.org. 

If you only see numbered directories on the left, your drive's root structure 
wasn't recovered. This doesn't mean your files are lost—check inside these folders; 
you might find intact subdirectory and file names, and the files may open properly. 
If not, try another file system entry or increase the “Level” on the “Select File 
System” screen. If issues persist, send us a recovery snapshot (see item 1 above). 

Search for your files: If you can't find the files you're looking for among all the 
files and folders, try searching for them—they might be stored in unexpected 
locations. To search, go to File → Search file name and enter part of the file name 
or its extension (for example, “*.jpg” or “myfiles*.*”). If that doesn't work, return 
to the “Select File System” screen and experiment with different options, including 
increasing the “Level” setting (see item 1 above). If you're still unsuccessful, send 
us a snapshot of your recovery (refer again to item 1 above). 

Files won’t open: If your recovered files display the right names and sizes but 
won't open or show strange hex characters, the recovery wasn't successful. Return 
to the “Select File System” screen and try other options. If that doesn't fix it, send 
us a snapshot as described above. 

 

mailto:support@runtime.org
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