
Step by Step: Doing a Data Recovery with GetDataBack Pro 

Here's how you do everything right when doing a data recovery with GetDataBack: 

Do not write anything anymore to the drive you want to recover the data from! 
This principle is not meant to terrorize you; it's meant to preserve your data. After a data loss your data is not 
protected by the operating system anymore the way it was before. The OS thinks that the space where your lost 
data resides is free and can be used. This means that the next copy operation, installation of programs, Internet 
surfing (which generates temporary files) and even booting from the drive can permanently overwrite your lost 
files.  

In this article we will call the drive from which you want to recover data the “Bad Drive”. Other drives, such as boot 
drive or drive to copy recovered data to will be called “good drives”. 

I. Setup 

I.I. Setting up a Recovery Computer 
Next, we will describe how to set up a Recovery Computer. 
 
Before you do anything else, do the following: 

1. If the Bad Drive is your boot drive (C:), then remove it from the system and attach it to another computer 
as a second drive. We'll show you how below in I.II. Remove the Bad Drive… 

2. If the Bad Drive is a second or external drive (please see the chapter I.II.II. External Drives), you may 
leave the setup as it is. Please jump to II.I. Installing GetDataBack.  

3. If your Bad Drive is a laptop or notebook drive, please go to section I.II.I. Laptop Drive. 

I.II. Remove the Bad Drive, and attach it as a second drive to the Recovery Computer 
If you haven't installed a drive before, please follow these easy steps. 

1. First - shut down your computer and unplug the power cable. You then need to open your computer 
casing, that's just a few tiny screws. You'll see your hard drive connected to the SATA cable and a power 
cable. You will probably need to unscrew a few more screws to free your hard drive. Then unplug the Bad 
Drive from the SATA cable and the power cable. That's it. Take the Bad Drive and install it to your 
Recovery Computer.  
 

 
 
You have two choices: 
 
- If you have another working computer, just install the Bad Drive as a second drive to that one. Please be 
aware that you must have enough free space on the hard drive of this computer to copy the recovered 
files to. Of course you can use a friend's computer for this - make sure your friend is okay with you coping 
all your recovered data to his drive. 
 
- If you don't have a second working computer, you can also set up your old system as the Recovery 
Computer. Just get another hard drive with enough space to later hold the recovered data and install 
Windows 7 or higher on it. Make this drive the boot drive of your computer and attach the Bad Drive as a 
second drive. 



2. It appears obvious, but before installing the Bad Drive as a second drive make sure the Recovery 
Computer boots into its good drive without any problem. After you verified this, install the Bad Drive as a 
second drive. All you need to do is to plug a free SATA cable as well as a power cable into the Bad Drive. If 
there is no free cable you can disconnect an eventually existing DVD drive and use its cables.  

3. Now plug the main power cable back in and start up the Recovery Computer. Make sure the machine boots 
into the (good) boot drive. If you notice it attempts to boot into the Bad Drive, stop that and modify the 
boot order in the BIOS first (common keys to enter the BIOS are F1, F2, F10, Delete, Esc, as well as key 
combinations like Ctrl + Alt + Esc or Ctrl + Alt + Delete). Once it neatly boots into the wanted good drive, 
make sure that the second drive (Bad Drive) is detected as well. Check this in Windows Disk Management. 
To get there open your computer “Run” field and type “msconfig” and press ENTER. Click Tools-
>Computer Management->Launch, then click “Computer Management->Storage->Disk Management”. If 
your Bad Drive doesn't show up here, the drive is either physically damaged or not installed correctly. If 
you know or suspect that the drive is broken, you need to send it to a data recovery lab. Otherwise, check 
the cabling and review your BIOS. If that doesn't help, take the computer to a local computer store and 
ask for help.  

I.II.I Special case - What if your drive is a Laptop drive? 
If you need to recover data from a Notebook or Laptop drive, you can either 

1. Remove the Bad Drive from the Laptop and attach it to the SATA cable of a Desktop computer. You'll need 
to find out how to remove the drive from your computer. Normally with modern Laptops the drives are 
removable and it's just a screw or two to get them out. Don't forget - always power down your computer 
before removing hardware. As soon as you've managed to remove the drive, you can attach it in the same 
way to your Recovery Computer as you would install a drive from a Desktop (see above, I.II. Remove 
the Bad Drive and attach it as a second drive to the Recovery Computer) 

2. An alternative is to create a WinPE boot CD and run GetDataBack from there. This is more complicated but 
works just as well and is an option if you cannot remove the Bad Drive from the Notebook. Please be 
aware that later on you need sufficient space on another drive to copy the recovered data to. This can for 
example be a USB drive that you attach to the Notebook or a Network drive. You'll find detailed 
information on how to create a WinPE boot disk on our website at http://www.runtime.org/peb.htm.  

3. A simpler option is booting the Notebook from our ready-to-use Runtime Live CD. This CD-ROM has 
GetDataBack preinstalled. You can download the ISO image from our Website at 
http://www.runtime.org/data-recovery-live-cd.htm. 

I.II.II. Special case - External Drives 
External drives, like for example USB drives or SD cards, can be recovered with GetDataBack just like internal 
drives.  
 
However - scanning the drive for your data might take longer when performed through USB. If possible, remove 
the drive from its casing and attach it directly to the SATA-cable of your computer. If you are afraid that 
unwrapping the drive is going to void its warranty, leave everything as it is and be patient. 

II. Installation 

II.I Installing GetDataBack Pro 
The hard work is behind you. Now that you've set up your Recovery Computer, download the free demo version of 
GetDataBack Pro from our website (http://www.runtime.org). GetDataBack Pro can recover data from Windows 
NTFS, FAT, exFAT, Linux EXT, and Mac HFS+ and APFS file systems. 

Install GetDataBack on the (good) boot (C:) drive of your Recovery Computer. 

 
 

http://www.runtime.org/peb.htm
http://www.runtime.org/data-recovery-live-cd.htm


III. Running GetDataBack Pro 

Start GetDataBack Pro by clicking on its icon. 

III.I. “Select Drive” Screen 
 
The first screen will look like this:  

 

You'll get a list of all the drives that are accessible in your system. Each square represents one of your drives. Now 
you will select the square that represents your Bad Drive. If you attached the drive as a second drive as explained 
above this would be the entry "DISK1 (183 GB)". If you had more than one hard drive in the system already it 
could be “DISK2”, “DISK3”, or so. It shouldn't be "DISK0” because that would mean the Bad Drive is still set up as 
the boot drive.  

Click the square for the Bad Drive. 
 



III.II Scanning the Bad Drive 

GetDataBack will now scan your Bad Drive for any available information regarding the original file system. The scan 
will take a couple of seconds only, maybe a couple of minutes. 

 

There are a couple of reasons why the scan can take longer: 

1. Your drive has physical problems. If the drive has a lot of bad sectors (damaged areas on the drive's 
platters that cannot be read anymore) or is otherwise damaged, the scan can take really long if it's ever 
going to finish.  
 
If you get only an occasional bad sector message, but the scan is otherwise progressing, choose "Ignore" 
in the warning windows and let the scan finish. 
 
But if you receive a lot of read error messages, or the scan seems to stall or is taking forever, your best 
bet is to stop what you are doing and to make an Image of your damaged drive first. By making an Image 
you will reduce the stress on the drive (which, if physically damaged, can fail at any moment). Once you 
have created the Image you can perform the data recovery for the Image instead of the drive - just select 
the Image you made in the “Select drive” of GetDataBack (click on “Image Files…”). You can use 
GetDataBack to make an Image, the only other thing you'll need is enough space on another drive to store 
the Image to. Instructions on how to create an Image are on our website at 
http://www.runtime.org/gdbimage.htm.  

2. You are scanning an external drive through the USB port. Scanning a drive through USB takes longer 
than scanning a drive that is connected to the internal SATA cable of your computer. Consider taking the 
drive out of its casing and attaching it directly to the SATA cable. See chapter I.II.II. External Drives 
above. 

3. You are scanning with a high “Level”. Look at the purple rectangle in the lower left corner. A Level-4 
(****) scan will take many hours to complete, as it will read every single sector, which is usually not 
necessary for a quality recovery.  

http://www.runtime.org/gdbimage.htm


III.III “Select File System” screen 

After the scan you will see the “Select File System” screen: 

 

On the left-hand side of the screen you will see a list of the possible file systems GetDataBack has found. Don't 
confuse the file system entries with the list of files and folders you are hoping to recover - you will see those in the 
next step of the software.  

Each entry represents a (possible) partition on the drive. If you had more than one partition on the drive which you 
need to recover (for example logical drives C:\ and D:\) you will probably have to go back and forth and select the 
corresponding entries separately in order to recover all files.  

The file system entries are constructed using the information GetDataBack has collected during the scan. Later, this 
information will be used to reconstruct the file system that was originally on the drive. By default, the most 
accurate file system entry is automatically on top of the list, so for the moment don't be too concerned about the 
other entries. 

Right-click a file system rectangle to obtain a detailed description of the found file system. This information is 
primarily used by our tech support staff.  

So, click on the first entry in the list. GetDataBack will now perform another scan before it shows the “Recovery 
Tree” screen. You can follow the progress in the progress window: 

This operation can take a couple of seconds, up to many hours, so you need to be patient. 



 

III.III.I No entries in “Select File System” screen 

If you do not see any entries here, this can be for the following reasons: 

1. Your drive is physically damaged and GetDataBack is unable to read enough sectors on the drive to 
gather the required information. If you were getting a lot of error messages during the scan or you already 
know that your drive has a physical problem, it might be too damaged for you to be able to recover your 
data with software. You might have to send your drive to a data recovery lab. Please contact our tech 
support - they will help you determine if this is the case. 

2. You are scanning an external drive.  
Since you don't have error checking when scanning through USB, possible errors while reading the drive 
are not reported to GetDataBack. It then can happen that the software is unable to read the necessary file 
system information and cannot collect enough information to come up with a file system entry. It's best 
(and much quicker) to attach the drive directly to the internal SATA cable. Please see above I.II.II. 
Special - External Drives. 

3. The drive is hardware encrypted. 
Some Western Digital USB drives have hardware encryption. Encryption and decryption are handled by the 
USB controller of the drive’s enclosure. If this is the case, you must use the Bad Drive with its original USB 
enclosure. 

4. The Level was too low. If you do not see an entry resembling the file system you are looking for, click on 
the purple “Level” rectangle in the lower left corner. Here you can increase the thoroughness with which 
the drive is scanned. Possible are levels * up to ****. 

 



III.IV. “Recovery Tree” 

The “recovery tree” screen will look like this: 

 

The screen will remind you of Windows Explorer. On the left side of the screen you see a tree of recovered 
directories and folders and a folder called "Lost files" created by GetDataBack, containing the files without directory 
information. 

When you open a folder on the left side, the files in this folder are displayed on the right side. 

First have a look at the left side. Does the directory tree look familiar to you? Do you see the folders that were on 
the drive you want to recover the data from? Does it seem that the directory structure is complete for this 
partition? 

Now open a folder that interests you on the left side and look on the right side. Do you see the files that you expect 
to be in this folder? Do you see the correct file names, and does it appear that the files are all there? 

Now open a few files in order to test them. The fact that you see the folders, files, file names, the right file size etc. 
is a good sign, but doesn't necessarily mean that the file content is there and that those files will be usable.  
You will not be able to test huge files or files that need to be imported correctly into their native application, like for 
example MySQL database files.  
Select files that are easy to check - for example Word documents (*.doc), pictures (*.jpg), graphics (*.gif). Open 
these files using the build-in file viewer by double-clicking or pressing F3 or ENTER. You can also open files with 
their native application – if that application is installed on the Recovery Computer: select a file, right-click it, and 
select “Open”. 

Do the files open fine, meaning you can see the file content, the text, picture etc.? 
If so, repeat the same process with a couple of more file in different folders.  
If all or at least the majority of files open okay, your recovery is looking good.  



In order to actually save your recovered files, you will need to copy them off the Bad Drive to another location. This 
can be a location on the Recovery Computer's boot drive, any other drive attached to this computer, a USB drive or 
you can copy the files to a network destination. Make sure this location has enough free space for all the files you 
need. Never copy the recovered files back to a location on the drive you just recovered them from (the Bad Drive), 
or you will overwrite them, and they will be gone forever!  

You may copy either selected files and folders by tagging them on the right side or the whole thing by selecting the 
top entry on the left side that says [FAT], [NTFS], [EXT] or so. Select the files/folders/volume you need and press 
the F5 or File->Copy on the main menu.  

To enable the copy function and to save your files you will need a license key for the software. You can purchase a 
license key online 24 hours a day on our website at http://www.runtime.org/buy_now.htm. You will receive the 
license key to your email address and on a confirmation screen immediately after submitting the order form. You 
do not have to run the software again - just enter the license key at any time in the demo version of GetDataBack. 
Go to Help->License in the main menu of the software and enter your registration name and key there.  

Now copy over your files. As soon as the copy operation has completed (which can take quite some time depending 
on the amount of data and the speed of your computer or network connection), make sure that all the files you 
need arrived safely on the destination drive. Do not at this point recycle your Bad Drive or format it or reinstall a 
new operating system. Keep the drive in its current state until you're absolutely sure that you salvaged all the data 
that you need. Only then should you decide whether or not you want to rebuild the system on this drive (reformat 
it, reinstall Windows and your other programs etc., copy back the recovered data to this drive). Never reuse a drive 
that has any physical problems, any bad sectors or a drive where you're not sure why the data on it became 
suddenly inaccessible.  

III.IV.I Problems & Troubleshooting 

1. What if you don't see your files and folders in the “Recovery Tree” screen? 
If you don't see the files you are looking for at all, go back to the “Select File System” screen and try other 
file system entries (if there are any). If you still cannot find your data, click on the purple “Level” rectangle 
in the lower left corner. Here you can increase the thoroughness with which the drive is scanned. Possible 
are levels * up to ****. If you still cannot find your data, send us a snapshot of your recovery along with 
a short description of what happened to your drive. You create a snapshot by clicking on Help->Snapshot 
for Support. This will create a small text file with detailed information about the options you selected in the 
software. Email this file to support@runtime.org.  

2. What if all you see on the left side is a list of numbered directories, but no or little directories with real 
names?  
The root directory structure of your drive could not be recovered. That doesn't automatically mean that 
the files and file names are unrecoverable. Look into the directories - if you're lucky at least the 
subdirectory names and file names are intact, and the files will open just fine. 
You may also go back to the “Select File System” screen and try other file system entries. Try to increase 
the “Level” (see 1 above). If this still does not help send us a snapshot of your recovery (see 1 above). 

3. What if you see a bunch of files and folders, but the specific file(s) you are looking for are not there? 
Search for your files - maybe they are hidden in some directory where you wouldn't expect them. To 
search for files, click on File->Search file name. Enter a part of the file name or the file's extension into 
the search mask (e.g, “*.jpg” or “myfiles*.*”). If you're still unable to locate the data you need, go back 
to the “Select File System” screen and try other entries. Try to increase the “Level” (see 1 above). If this 
still does not help send us a snapshot of your recovery (see 1 above). 

4. What if you see your folders, files, file names - even with the right file size - but when you try to open a 
file to test it, it either won't open at all or all you see are weird hex characters instead of your file content 
(text, picture)? There is something wrong with your recovery at this point and you won't be able to 
recover your files like that. First go back to the “Select File System” screen and try other file system 
entries. If that doesn't help, please send us a snapshot (see 1 above).  
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